System Requirements

> Browsers

To fully access the Clearinghouse’s online services, you will need one of the following browsers (beta versions of browsers are not supported):

> PDF Documents

PDF documents on our Web site require Adobe Reader 9 or higher. The free Adobe Reader can be downloaded from the Adobe Web site.

> Security Certificate Update

If you are a college or university experiencing issues connecting to the Clearinghouse secure site, you may need to update the security certificate used by your application or service to connect to secure.studentclearinghouse.org. Please see our Certificate Help page.